Can't View Pages or Posts

Home Forums Troubleshooting and How-To Can't View Pages or Posts

Tagged: ,

This topic contains 19 replies, has 8 voices, and was last updated by  ikailo 7 years ago.

Viewing 15 posts - 1 through 15 (of 20 total)
  • Author
    Posts
  • #669

    jconrad
    Participant

    Are there other solutions aside from re-saving permalinks? I have tried this numerous times, but I am unable to load any pages or posts. Just get 404 errors…

    Thanks

    #1479

    jconrad
    Participant

    I’ll only add that I can view all of the homepages and get into the admin pages, I just can’t see the pages/posts within the sites.

    #1480

    jconrad
    Participant

    It seems like it must have to do with permalinks given that my search functions work and send me to working results pages that do not use friendly permalinks… anyone with any thoughts on how to fix this problem? kind of freaking out here, I have a lot of sites in the hive at this point.

    #1482

    ikailo
    Participant

    Please check that mod-rewite is installed and working. You may need to check with your host.

    When / how did this start happening?

    I’m remote right now (at the cottage) so please send me an email if you still have issues, as it is easier to respond to.

    #1483

    Ronal
    Participant

    I just submitted a new topic about this. Seems my .htaccess info has disappeared, even after manually trying to “reset” permalink settings. Now all links on all blogs are broken.

    #1490

    Ronal
    Participant

    First request never posted. I can’t posts or pages. Any update or suggestions on this? Mod rewrite is installed, I tried “resetting” my permalinks, nothing seems to be working. I downloaded my htaccess file and it’s blank. Help please.

    #1503

    TheShamanMarketer
    Participant

    I have the same phenomenon here.

    As soon as I update the permalink structure in one of the hive’s blogs, everything except homepages and “non-pretty-urls” goes 404.

    Reason? for some reason the .htaccess is not updated, but emptied, it only contains the WordPress start/end comments.

    So my workaround: use the same permalink structure on all of your hive’s blogs.

    First (before activating wp hive) set the permalinks in the original blog. Make a copy of the .htaccess via FTP, the file manager plugin, cpanel, or whatever.

    Activate wp hive, create the blogs you need, edit/save permalinks for each of them and use the same settings for all.

    When done, replace the empty .htaccess with the one you saved. Make it non-writable, just in case…

    #1504

    Michael143
    Participant

    We have the same issue jconrad. I’ll follow ikailo’s solution for this. I find it hard to fix it. I’ll try it later. Hope it’ll be okay.

    Thanks a lot for information ikailo.

    P90X Workout

    #1506

    christineb1979
    Participant

    Same i encounter the same problem..

    #1507

    christineb1979
    Participant

    Any updates from this

    Some tips for a dog trainer: weimaraner obedience and weimaraner puppy training.

    #1509

    superscott597
    Participant

    @ShamanMa Thanks for pinpointing the problem! That’s exactly what it’s doing. I was having the same problem as jconrad and using the rewrite code from a working .htaccess file fixed all my sites instantaneously. Hopefully this bug will be addressed soon, as it can be a pain to have to copy it every time or wait to test the sites until all have been installed and set up.

    For those that don’t know quite what the .htaccess should look like, here is what mine uses to display the pretty permalinks:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>
    # END WordPress

    Cheers!

    -Scott

    #1510

    wwday3
    Participant

    Same issue. Same (annoying) solution. Why would WP remove an existing set of .htaccess code? Does it have something to do with the multi-site feature in the new release?

    Right now it means for each new hive blog we add, we have to remember to update the .htaccess file or all blogs will suddenly not work. Very annoying.

    #1511

    wwday3
    Participant

    Bump. This is a major issue.

    #1512

    ikailo
    Participant

    It is for this reason that it is recommended to make .htaccess read-only after it contains the correct information.

    If you are running subdirectory sites (domain.com/blog1) then this is what .htaccess should look like:

    # BEGIN WordPress
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index.php$ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*.php)$ $2 [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /index.php [L]
    </IfModule>

    # END WordPress

    If you’re not using subdirectory sites (domains or subdomains only), you can use the rewrite rules posted by superscott597 above.

    .htaccess rarely needs to change, so once it is written, make it read-only, and you should not have this problem anymore.

    #1514

    wwday3
    Participant

    That’s not the point. I tested this out with a “normal” WP site. Clicking update in the Permalinks panel did not “clear” the .htaccess file. Why, in a WP-Hive environment, does it get cleared? That is not normal behavior for a WP install.

    BTW, the only time I’ve heard anyone suggest making .htaccess read-only was in regards to anti-hacking strategies.

Viewing 15 posts - 1 through 15 (of 20 total)

You must be logged in to reply to this topic.