just upgraded to WP 3.1 – error message help!

Home Forums Troubleshooting and How-To just upgraded to WP 3.1 – error message help!

Tagged: 

This topic contains 14 replies, has 8 voices, and was last updated by  dlmeckes 6 years, 8 months ago.

Viewing 15 posts - 1 through 15 (of 15 total)
  • Author
    Posts
  • #704

    msohal
    Participant

    I have just upgraded to WP 3.10 from 3.05 and have this error message

    “Fatal error: Call to a member function suppress_errors() on a non-object in /home/msohal/public_html/wp-content/plugins/wp-hive/includes/class.wphive.php on line 69”

    can someone please help

    Mandip

    #1559

    dragnmuse
    Participant

    I too got an error when updating WP. Fortunately, I had a copy of the previous version. I ended up having to roll back to WP 3.0.5. It would appear that WP 3.1 and WP-Hive don’t play well together.

    If you don’t have a copy of WP 3.0.5, you can get it from wp.org: http://wordpress.org/download/release-archive/

    Good luck! I know that my stomach about hit the floor when I wiped out my whole hive. But, rolling back works. Good news is it didn’t mess with the database.

    I just wrote over every file with the old one except for the wpconfig file and my wp-content file.

    #1560

    wwday3
    Participant

    Same experience here. Except, my issue was with Fatal error: Call to undefined function wp_cache_get() in /home/content/*********************/wp-includes/functions.php on line 336

    Apparently wp-hive is using (or at least causing execution of) WP functions that have been deprecated. Rolling back to 3.0.5 works fine, but it may mean staying at that release indefinitely.

    So, anyone know yet what the future of wp-hive is? Or, has anyone figured out a nice clean way to migrate to WordPress multi-site??

    #1561

    msohal
    Participant

    thank you so much – I did this and it worked perfectly.

    My heart had skipped a beat

    Mandip

    #1562

    hmemcpy
    Participant

    Same error after upgrading. I found this post on the WordPress support forum with people having the same problem: http://wordpress.org/support/topic/upgrade-to-31-wp_cache_get-issue

    I reverted back to 3.0.5 as well in the meantime. Can’t wait for the fix!

    #1563

    dayer4b
    Participant

    I just went through this also. I attempted to roll back to an earlier version but that failed miserably. Fortunately I was able (after several hours of freaking out) to start from scratch, rebuild my sites w/ wp-hive and import the old databases. Looks like I haven’t lost anything!

    I really hope somebody picks up development on WP-Hive. I love this plugin! WordPress MU doesn’t seem as simple or usable. I’m going to look into that soon. Right now I’m using WP 3.0 and my plan for the immediate future is DON’T UPGRADE. I don’t like that plan, but that’s all I can do. :(

    #1564

    dlmeckes
    Participant

    I exactly followed the fix offered at

    http://wordpress.org/support/topic/upgrade-to-31-wp_cache_get-issue

    but I got the same line 69 error as I got before. I’m going to try this fix with a different installation.

    Meanwhile, I’m not upgrading. I’m not a programmer and I can’t fix something I have come to depend on.

    #1565

    ikailo
    Participant

    Can someone please test this version?

    http://downloads.wordpress.org/plugin/wp-hive.0.6.2.zip

    Once I get confirmation that it works with 3.1 and 3.0.5, I will tag it as stable.

    #1566

    hmemcpy
    Participant

    @ikailo

    It works in both! Thank you so much for fixing this, I know you’re not developing the plugin anymore, but it’s an amazing one, much better than anything else that’s available!

    Thanks again!

    #1567

    pandf
    Participant

    still has the PHP Fatal error: Call to a member function suppress_errors() on a non-object in /wp-content/plugins/wp-hive/includes/class.wphive.php on line 69

    #1568

    dlmeckes
    Participant

    sorry to report:

    Fatal error: Call to a member function suppress_errors() on a non-object in /my_place/plugins/wp-hive/includes/class.wphive.php on line 69

    #1569

    dlmeckes
    Participant

    I looked at this again because I didn’t like the answer. I decided that I would start with one of the hives I had not upgraded and I replaced the old wp-hive plugin with the new. Then I did the WordPress upgrade and… it worked!

    It just didn’t work when I upgraded wp-hive after the WordPress upgrade.

    I know it’s too much to keep up and I wish I could code, because I rely on this plug-in.

    #1570

    ikailo
    Participant

    dl: Try replacing the db.php file in /wp-content/ with the one from the new version of WP Hive: /wp-conten/plugins/wp-hive/db.php.

    #1571

    dlmeckes
    Participant

    Thanks, I’ll give that a try and report back.

    #1572

    dlmeckes
    Participant

    I had the new version of the db.php. This time, before I attempted the upgrade on one of my hives, I disabled every plugin except wp-hive. The upgrade went fine and I could reactivate my plugins.

    Hive does NOT play well with SEO plugins.

    Thank you for the update. I’ve come to rely on this plugin.

Viewing 15 posts - 1 through 15 (of 15 total)

You must be logged in to reply to this topic.