Permalink URL’s not working

Home Forums Troubleshooting and How-To Permalink URL’s not working

Tagged: 

This topic contains 28 replies, has 10 voices, and was last updated by  Mbird 6 years, 11 months ago.

Viewing 14 posts - 16 through 29 (of 29 total)
  • Author
    Posts
  • #982

    Timmie
    Participant

    @ikailo You are doing a good job, well done!

    I have been finding this permalink issue slightly frustrating. I included the above code but there seems to be no effect apart from making one of my blogs disappear completely. Is there something I’m not doing right? Thanks

    #989

    ikailo
    Participant

    Timmie: Sorry, I haven’t had an opportunity to test this completely, so I can’t provide more insight. It is a more technical issue than it might appear – hopefully something that can be solved within time.

    #1086

    sallam
    Participant

    I’m using the new hp-hive version.

    Here is what’s in my .htaccess before I add a new site:

    # BEGIN WordPress

    <IfModule mod_rewrite.c>

    RewriteEngine On

    RewriteBase /

    RewriteCond %{REQUEST_FILENAME} !-f

    RewriteCond %{REQUEST_FILENAME} !-d

    RewriteRule . /index.php [L]

    </IfModule>

    # END WordPress

    I’m using custom friendly URL

    /%postname%.html

    and here is my .htaccess after adding a new site:

    # BEGIN WordPress

    # END WordPress

    But, as andrewl mentioned above, the best solution so far is to make our htaccess file read-only when the last time we edited permalink is the way we want for all sites. Usually, if you prefer friendly urls, you’d want all your sites to use them the same way the original site does.

    Once I changed htaccess file permission from 644 to 444, new sites couldn’t change anything in it. I only have to set the permalink in new sites to use the same custom friendly urls that I’m using in all other sites. It will complain that the file is not writable, but thats fine. Leave it at that. Firendly urls will work in the new site once you set it in permalink.

    The important advantage is that adding new sites will not mess current sites if we make the htaccess file’s permissions set at: 444 (read-only), and we only have to do this once.

    #1087

    ikailo
    Participant

    Hmmm… I had actually fixed this in 0.5. Concluded that the WP install function flushes the rewrite rules at the end of the install process and that the fix was to tell WordPress not to do it.

    If it’s still clearing your .htaccess, then I’d hazard there’s something wrong either with the WP Hive install, or WP is set up differently than I had expected.

    Is there anything about your WordPress configuration and/or install process that is ‘non-standard’?

    #1523

    jamesquin
    Participant

    Was this issue ever solved as it is REALLY annoying. I have 60 blogs set up – ALL are set to custom permalinks and NOTHING has been changed in any permalinks settings. I have made the htaccess file read only. We are ONLY adding content and pages to blogs but EVERY single time we work on any site the htaccess file is overwritten (ie blank) and I have to paste the code back into the file. This means my sites are almost permanently down and I have to keep checking to see if the links are working.

    There has to be a permanent solution to this – I see several work around’s but this does not appear to fix the problem or stop it keep happening. Any help or solution much appreciated as I am sure this is frustrating many more people.

    #1530

    ikailo
    Participant

    Unfortunately, the only solution right now is to make sure .htaccess is read-only across the board: 555. If WordPress is overwriting, then you may have a 655 or 755 permission on it. I recommend you double check this.

    For the permanent solution, this ticket must be committed to core. At this time, it looks like it will be a while before that happens.

    Also, bear in mind that .htaccess can be flushed even when just LOADING the options-permalinks page in WP Admin. This ticket is intended to fix this behavior.

    #1538

    jamesquin
    Participant

    I have made htaccess read only – numerous times yet it is still overwritten!!

    #1540

    ikailo
    Participant

    This is very strange behavior. Maybe you have a plugin that is forcing it to be writable?

    Neither WordPress or WP Hive attempts to change permissions on .htaccess. If WordPress finds that it is not writable, then it will advise you to make a manual update when you re-save the permalinks options.

    Are you on a Linux server?

    #1541

    jamesquin
    Participant

    Yes, Linux server. It is very frustrating

    #1542

    ikailo
    Participant

    Can you send me the URL(s) of your site, via email?

    #1543

    jamesquin
    Participant
    #1550

    jamesquin
    Participant

    Still unable to resolve this. I confirm all settings are the same on each blog, htacces is set to read only and I’ve even disabled virtually all the plugins. It is VERY annoying and disrupting to my business. I’m looking to see if there are other viable alternatives to WPHive that will do what I want but save having this probem – any suggestions anyone?

    #1552

    wwday3
    Participant

    I posted this elsewhere, but I guess you can ignore that thread. I didn’t see this thread.

    I was having the same issue as jamesquin. Sites were reverting to blank htaccess rules even when I did nothing to them (not even a visit – they are autoblogs). Modifying the htaccess permissions (to 555) does seem to protect the htaccess when I’ve tried that approach.

    This was not happening with older versions of wp-hive and prior to WP 3. Could it have something to do with the new multi-site characteristics of WP 3?

    It is not good to have a dozen sites – especially autoblog sites – suddenly stop working.

    #1554

    Mbird
    Participant

    Will there be a solution for this issue ever?

Viewing 14 posts - 16 through 29 (of 29 total)

You must be logged in to reply to this topic.