Site not redirecting properly

Home Forums Troubleshooting and How-To Site not redirecting properly

This topic contains 5 replies, has 3 voices, and was last updated by  jaylperry 7 years, 5 months ago.

Viewing 6 posts - 1 through 6 (of 6 total)
  • Author
  • #685


    I just added a site (not sub directory or subdomain) to an existing hive. When I click on install site I get “Firefox has detected that the server is redirecting the request for this address in a way that will never complete.”

    So far I have

    – deleted an recreated the hive entry

    – removed and reinstalled wp-hive

    – checked the .htaccess (normal)

    Not sure ehat to check next



    OK, so I upgraded the install to 3.0.1 and the error went away



    I love wp-hive. It looks like it will make my life much easier.

    I’m having a problem setting it up to do subdomains.

    I’m on bluehost (shared) with a wordpress installation from simple scripts.

    I have my wordpress installed in public_html (www).

    I add a new site:

    domain name:

    subdirectory: /hivetest

    prefix: ht2_

    I save it and install it.

    I make my permalinks pretty and chmod .htaccess (in public_html) to 444 (read only).

    I create the site with title, login, password, email.

    YAY!!! It works. I can see my site, login to wp-admin, change stuff. Hurrah!

    Now… I want to make this installation a subdomain –

    I go into my cPanel -> subdomains

    I type ‘hivetest’ as the subdomain for

    document root: ?????

    No matter what I’ve tried here (public_html, public_html/hivetest, public_html/wp-content, etc, etc…), I can’t get the subdirectory to work. Depending on where I point it, I’ll get a 404, or the generic bluehost.html site, or a blank page, or an ‘unknown host’ message.

    What am I doing wrong?

    Is it a problem with a simple scripts installation? Am I pointing to the wrong document root? Do I need to do some kind of editing in my .htaccess? Do I need a dedicated ip?

    Any ideas?



    If you’re getting the ‘unknown host’ error, then you’ve got it pointed correctly in your control panel (It should be pointing to the public_html directory).

    Now, just add that site to the WP Hive admin page within your root site.


    Subdirectory: /

    Prefix: ht2_

    If you are moving it from subdirectory to subdomain, then you will have to edit the home and siteurl options accordingly. There may be other factors to deal with as well. You may want to review this page for consideration.



    Aha!!! I was trying to point the subdomain AFTER I created the site on in a subdirectory.

    Thank you. It works beautifully now!




    So, how can I send a one-time donation?

Viewing 6 posts - 1 through 6 (of 6 total)

You must be logged in to reply to this topic.